support.idalko.com down due to infrastructure problem
Incident Report for idalko
Resolved
servcie up again
Posted Dec 19, 2020 - 10:12 CET
Identified
Host is down ... recovery on its way
Posted Dec 19, 2020 - 09:47 CET
This incident affected: Idalko Support.