Scheduled maintenance on support.idalko.com
Incident Report for idalko
Resolved
This incident has been resolved.
Posted Sep 27, 2020 - 16:19 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 27, 2020 - 16:09 CEST
Investigating
Security patches are being applied
Posted Sep 27, 2020 - 16:09 CEST
This incident affected: Idalko Support.